aboutsummaryrefslogtreecommitdiff
path: root/hosts/sparrow/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/sparrow/default.nix')
-rw-r--r--hosts/sparrow/default.nix46
1 files changed, 30 insertions, 16 deletions
diff --git a/hosts/sparrow/default.nix b/hosts/sparrow/default.nix
index c7b175f..4eb87b0 100644
--- a/hosts/sparrow/default.nix
+++ b/hosts/sparrow/default.nix
@@ -1,8 +1,34 @@
-{ inputs, pkgs, ... }:
+{
+ inputs,
+ lib,
+ pkgs,
+ ...
+}:
{
system.stateVersion = "24.05";
- imports = [ ./hardware.nix ];
+ imports = [ ./filesystems ];
+
+ hardware = {
+ enableRedistributableFirmware = true;
+ cpu.intel.updateMicrocode = true;
+ };
+
+ boot.loader = {
+ systemd-boot.enable = true;
+ efi.canTouchEfiVariables = true;
+ };
+ boot.initrd.availableKernelModules = [
+ "xhci_pci"
+ "ahci"
+ "usb_storage"
+ "sd_mod"
+ ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.binfmt.emulatedSystems = [
+ "aarch64-linux"
+ "riscv64-linux"
+ ];
home-manager = {
useGlobalPkgs = true;
@@ -14,25 +40,13 @@
};
};
+ time.timeZone = "America/Detroit";
networking = {
hostName = "sparrow";
networkmanager.enable = true;
};
- time.timeZone = "America/Detroit";
-
- boot = {
- loader = {
- systemd-boot.enable = true;
- efi.canTouchEfiVariables = true;
- };
- binfmt.emulatedSystems = [
- "aarch64-linux"
- "riscv64-linux"
- ];
- };
-
- # Since I don't always carry my split keyboard, remap CAPS to left CTRL.
+ # Since I don't always use my split keyboard, remap CAPS to left CTRL.
console.useXkbConfig = true;
services = {
xserver.xkb.options = "ctrl:swapcaps";