aboutsummaryrefslogtreecommitdiff
path: root/hosts/thor/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/thor/default.nix')
-rw-r--r--hosts/thor/default.nix11
1 files changed, 7 insertions, 4 deletions
diff --git a/hosts/thor/default.nix b/hosts/thor/default.nix
index 0ec2fa9..62071e8 100644
--- a/hosts/thor/default.nix
+++ b/hosts/thor/default.nix
@@ -20,10 +20,10 @@
defaultGateway.address = "10.44.0.1";
interfaces.eno1 = {
useDHCP = false;
- ipv4.addresses = [{
+ ipv4.addresses = lib.singleton {
address = "10.44.4.102";
prefixLength = 16;
- }];
+ };
};
};
@@ -36,7 +36,10 @@
programs.motd = {
enable = true;
- networkInterfaces = lib.lists.singleton "eno1";
- servicesToCheck = [ "caddy" "gotosocial" ];
+ networkInterfaces = [ "eno1" ];
+ servicesToCheck = [
+ "caddy"
+ "gotosocial"
+ ];
};
}