aboutsummaryrefslogtreecommitdiff
path: root/hosts/thor/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/thor/default.nix')
-rw-r--r--hosts/thor/default.nix48
1 files changed, 30 insertions, 18 deletions
diff --git a/hosts/thor/default.nix b/hosts/thor/default.nix
index 62071e8..6ded704 100644
--- a/hosts/thor/default.nix
+++ b/hosts/thor/default.nix
@@ -1,8 +1,35 @@
-{ lib, inputs, ... }:
+{
+ inputs,
+ lib,
+ pkgs,
+ ...
+}:
{
system.stateVersion = "24.05";
- imports = [ ./hardware.nix ];
+ imports = [
+ ./filesystems
+ ./modules
+ ];
+
+ hardware = {
+ enableRedistributableFirmware = true;
+ cpu.amd.updateMicrocode = true;
+ };
+
+ boot.loader = {
+ systemd-boot.enable = true;
+ efi.canTouchEfiVariables = true;
+ };
+ boot.initrd.availableKernelModules = [
+ "xhci_pci"
+ "ahci"
+ "ehci_pci"
+ "usb_storage"
+ "usbhid"
+ "sd_mod"
+ ];
+ boot.kernelModules = [ "kvm-amd" ];
home-manager = {
useGlobalPkgs = true;
@@ -14,6 +41,7 @@
};
};
+ time.timeZone = "America/Detroit";
networking = {
hostName = "thor";
nameservers = [ "10.44.0.1" ];
@@ -26,20 +54,4 @@
};
};
};
-
- time.timeZone = "America/Detroit";
-
- boot.loader = {
- systemd-boot.enable = true;
- efi.canTouchEfiVariables = true;
- };
-
- programs.motd = {
- enable = true;
- networkInterfaces = [ "eno1" ];
- servicesToCheck = [
- "caddy"
- "gotosocial"
- ];
- };
}