aboutsummaryrefslogtreecommitdiff
path: root/users/tdback/modules/ncmpcpp/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/tdback/modules/ncmpcpp/default.nix')
-rw-r--r--users/tdback/modules/ncmpcpp/default.nix139
1 files changed, 114 insertions, 25 deletions
diff --git a/users/tdback/modules/ncmpcpp/default.nix b/users/tdback/modules/ncmpcpp/default.nix
index 970dba3..839ce34 100644
--- a/users/tdback/modules/ncmpcpp/default.nix
+++ b/users/tdback/modules/ncmpcpp/default.nix
@@ -35,31 +35,120 @@
};
bindings = [
- { key = "j"; command = "scroll_down"; }
- { key = "k"; command = "scroll_up"; }
- { key = "h"; command = [ "previous_column" "jump_to_parent_directory" ]; }
- { key = "l"; command = [ "next_column" "enter_directory" "run_action" "play_item" ]; }
- { key = "u"; command = "page_up"; }
- { key = "d"; command = "page_down"; }
- { key = "ctrl-u"; command = "page_up"; }
- { key = "ctrl-d"; command = "page_down"; }
- { key = "g"; command = "move_home"; }
- { key = "G"; command = "move_end"; }
- { key = "n"; command = "next_found_item"; }
- { key = "N"; command = "previous_found_item"; }
- { key = "J"; command = "move_sort_order_down"; }
- { key = "K"; command = "move_sort_order_up"; }
- { key = "f"; command = [ "show_browser" "change_browse_mode" ]; }
- { key = "s"; command = [ "reset_search_engine" "show_search_engine" ]; }
- { key = "m"; command = "toggle_media_library_columns_mode"; }
- { key = "x"; command = "delete_playlist_items"; }
- { key = "U"; command = "update_database"; }
- { key = "P"; command = "show_playlist"; }
- { key = "t"; command = "show_tag_editor"; }
- { key = "v"; command = "show_visualizer"; }
- { key = "."; command = "show_lyrics"; }
- { key = "+"; command = "show_clock"; }
- { key = "="; command = "volume_up"; }
+ {
+ key = "j";
+ command = "scroll_down";
+ }
+ {
+ key = "k";
+ command = "scroll_up";
+ }
+ {
+ key = "h";
+ command = [
+ "previous_column"
+ "jump_to_parent_directory"
+ ];
+ }
+ {
+ key = "l";
+ command = [
+ "next_column"
+ "enter_directory"
+ "run_action"
+ "play_item"
+ ];
+ }
+ {
+ key = "u";
+ command = "page_up";
+ }
+ {
+ key = "d";
+ command = "page_down";
+ }
+ {
+ key = "ctrl-u";
+ command = "page_up";
+ }
+ {
+ key = "ctrl-d";
+ command = "page_down";
+ }
+ {
+ key = "g";
+ command = "move_home";
+ }
+ {
+ key = "G";
+ command = "move_end";
+ }
+ {
+ key = "n";
+ command = "next_found_item";
+ }
+ {
+ key = "N";
+ command = "previous_found_item";
+ }
+ {
+ key = "J";
+ command = "move_sort_order_down";
+ }
+ {
+ key = "K";
+ command = "move_sort_order_up";
+ }
+ {
+ key = "f";
+ command = [
+ "show_browser"
+ "change_browse_mode"
+ ];
+ }
+ {
+ key = "s";
+ command = [
+ "reset_search_engine"
+ "show_search_engine"
+ ];
+ }
+ {
+ key = "m";
+ command = "toggle_media_library_columns_mode";
+ }
+ {
+ key = "x";
+ command = "delete_playlist_items";
+ }
+ {
+ key = "U";
+ command = "update_database";
+ }
+ {
+ key = "P";
+ command = "show_playlist";
+ }
+ {
+ key = "t";
+ command = "show_tag_editor";
+ }
+ {
+ key = "v";
+ command = "show_visualizer";
+ }
+ {
+ key = ".";
+ command = "show_lyrics";
+ }
+ {
+ key = "+";
+ command = "show_clock";
+ }
+ {
+ key = "=";
+ command = "volume_up";
+ }
];
};
}