From a9b1f9b419e4db9732a1ec5eef9dcead5a8f183d Mon Sep 17 00:00:00 2001
From: tdback <tyler@tdback.net>
Date: Sun, 26 Jan 2025 11:36:10 -0500
Subject: flake: overhaul on flake, added deploy-rs

---
 flake.nix | 337 +++++++++++++++++++++++++++++++-------------------------------
 1 file changed, 168 insertions(+), 169 deletions(-)

(limited to 'flake.nix')

diff --git a/flake.nix b/flake.nix
index 2db1764..80598e5 100644
--- a/flake.nix
+++ b/flake.nix
@@ -10,6 +10,7 @@
       url = "github:ryantm/agenix";
       inputs.nixpkgs.follows = "nixpkgs";
     };
+    deploy-rs.url = "github:serokell/deploy-rs";
   };
 
   outputs =
@@ -18,173 +19,171 @@
       helpers = import ./modules { inherit inputs; };
       inherit (helpers) mergeSets mkSystem;
     in
-    {
-      nixosConfigurations = mergeSets [
-        (mkSystem "frigg" "x86_64-linux" inputs.nixpkgs [
-          {
-            type = "profiles";
-            modules = [
-              "common"
-              "podman"
-              "upgrade"
-              "wireguard"
-              "zfs"
-            ];
-          }
-          {
-            type = "scripts";
-            modules = [
-              "motd"
-              "pushover"
-              "zquota"
-            ];
-          }
-          {
-            type = "services";
-            modules = [
-              "cgit"
-              "proxy"
-              "sftpgo"
-              "ssh"
-            ];
-          }
-        ])
-        (mkSystem "heimdall" "x86_64-linux" inputs.nixpkgs [
-          {
-            type = "profiles";
-            modules = [
-              "common"
-              "upgrade"
-            ];
-          }
-          {
-            type = "scripts";
-            modules = [
-              "motd"
-              "pushover"
-            ];
-          }
-          {
-            type = "services";
-            modules = [
-              "dns"
-              "searx"
-              "ssh"
-            ];
-          }
-        ])
-        (mkSystem "loki" "aarch64-linux" inputs.nixpkgs [
-          {
-            type = "profiles";
-            modules = [
-              "common"
-              "upgrade"
-            ];
-          }
-          {
-            type = "scripts";
-            modules = [
-              "motd"
-              "pushover"
-            ];
-          }
-          {
-            type = "services";
-            modules = [
-              "matrix"
-              "ssh"
-            ];
-          }
-        ])
-        (mkSystem "odin" "x86_64-linux" inputs.nixpkgs [
-          {
-            type = "containers";
-            modules = [
-              "freshrss"
-              "jellyfin"
-              "lubelogger"
-              "pinchflat"
-              "vaultwarden"
-              "watchtower"
-            ];
-          }
-          {
-            type = "profiles";
-            modules = [
-              "common"
-              "podman"
-              "share"
-              "upgrade"
-              "wireguard"
-              "zfs"
-            ];
-          }
-          {
-            type = "scripts";
-            modules = [
-              "motd"
-              "pushover"
-              "zquota"
-            ];
-          }
-          {
-            type = "services";
-            modules = [
-              "immich"
-              "proxy"
-              "ssh"
-            ];
-          }
-        ])
-        (mkSystem "sparrow" "x86_64-linux" inputs.nixpkgs (
-          inputs.nixpkgs.lib.singleton {
-            type = "profiles";
-            modules = [
-              "common"
-              "vpn"
-              "xorg"
-            ];
-          }
-        ))
-        (mkSystem "thor" "x86_64-linux" inputs.nixpkgs [
-          {
-            type = "profiles";
-            modules = [
-              "common"
-              "upgrade"
-              "wireguard"
-            ];
-          }
-          {
-            type = "scripts";
-            modules = [
-              "motd"
-              "pushover"
-            ];
-          }
-          {
-            type = "services";
-            modules = [
-              "fediverse"
-              "ssh"
-              "web"
-            ];
-          }
-        ])
-        (mkSystem "woodpecker" "x86_64-linux" inputs.nixpkgs (
-          inputs.nixpkgs.lib.singleton {
-            type = "profiles";
-            modules = [
-              "common"
-              "fstrim"
-              "libvirtd"
-              "nvidia"
-              "steam"
-              "wireshark"
-              "xorg"
-            ];
-          }
-        ))
-      ];
-    };
+    mergeSets [
+      (mkSystem "frigg" "x86_64-linux" inputs.nixpkgs [
+        {
+          type = "customs";
+          modules = [ "cgit" ];
+        }
+        {
+          type = "profiles";
+          modules = [
+            "common"
+            "upgrade"
+            "wireguard"
+            "zfs"
+          ];
+        }
+        {
+          type = "scripts";
+          modules = [
+            "motd"
+            "pushover"
+            "zquota"
+          ];
+        }
+        {
+          type = "services";
+          modules = [
+            "llm"
+            "sftpgo"
+            "ssh"
+          ];
+        }
+      ])
+      (mkSystem "heimdall" "x86_64-linux" inputs.nixpkgs [
+        {
+          type = "profiles";
+          modules = [
+            "common"
+            "upgrade"
+          ];
+        }
+        {
+          type = "scripts";
+          modules = [
+            "motd"
+            "pushover"
+          ];
+        }
+        {
+          type = "services";
+          modules = [
+            "dns"
+            "searx"
+            "ssh"
+          ];
+        }
+      ])
+      (mkSystem "loki" "aarch64-linux" inputs.nixpkgs [
+        {
+          type = "profiles";
+          modules = [
+            "common"
+            "upgrade"
+          ];
+        }
+        {
+          type = "scripts";
+          modules = [
+            "motd"
+            "pushover"
+          ];
+        }
+        {
+          type = "services";
+          modules = [
+            "matrix"
+            "ssh"
+          ];
+        }
+      ])
+      (mkSystem "odin" "x86_64-linux" inputs.nixpkgs [
+        {
+          type = "containers";
+          modules = [
+            "freshrss"
+            "jellyfin"
+            "lubelogger"
+            "pinchflat"
+            "vaultwarden"
+            "watchtower"
+          ];
+        }
+        {
+          type = "profiles";
+          modules = [
+            "common"
+            "podman"
+            "upgrade"
+            "wireguard"
+            "zfs"
+          ];
+        }
+        {
+          type = "scripts";
+          modules = [
+            "motd"
+            "pushover"
+            "zquota"
+          ];
+        }
+        {
+          type = "services";
+          modules = [
+            "immich"
+            "ssh"
+          ];
+        }
+      ])
+      (mkSystem "sparrow" "x86_64-linux" inputs.nixpkgs (
+        inputs.nixpkgs.lib.singleton {
+          type = "profiles";
+          modules = [
+            "common"
+            "vpn"
+            "xorg"
+          ];
+        }
+      ))
+      (mkSystem "thor" "x86_64-linux" inputs.nixpkgs [
+        {
+          type = "profiles";
+          modules = [
+            "common"
+            "upgrade"
+            "wireguard"
+          ];
+        }
+        {
+          type = "scripts";
+          modules = [
+            "motd"
+            "pushover"
+          ];
+        }
+        {
+          type = "services";
+          modules = [
+            "fediverse"
+            "ssh"
+            "website"
+          ];
+        }
+      ])
+      (mkSystem "woodpecker" "x86_64-linux" inputs.nixpkgs (
+        inputs.nixpkgs.lib.singleton {
+          type = "profiles";
+          modules = [
+            "common"
+            "fstrim"
+            "libvirtd"
+            "nvidia"
+            "steam"
+            "wireshark"
+            "xorg"
+          ];
+        }
+      ))
+    ];
 }
-- 
cgit v1.2.3