30 lines
680 B
Nix
30 lines
680 B
Nix
{ ... }:
|
|
let
|
|
directories = [
|
|
"/opt/freshrss"
|
|
];
|
|
port = "8888";
|
|
in
|
|
{
|
|
systemd.tmpfiles.rules = map (x: "d ${x} 0755 share share - -") directories;
|
|
virtualisation.oci-containers.containers.freshrss = {
|
|
image = "freshrss/freshrss:latest";
|
|
autoStart = true;
|
|
ports = [
|
|
"${port}:80"
|
|
];
|
|
volumes = [
|
|
"/opt/freshrss/data:/var/www/FreshRSS/data"
|
|
"/opt/freshrss/extensions:/var/www/FreshRSS/extensions"
|
|
];
|
|
environment = {
|
|
TZ = "America/Detroit";
|
|
CRON_MIN = "*/20";
|
|
};
|
|
};
|
|
|
|
services.caddy.virtualHosts."newspaper.tdback.net".extraConfig = ''
|
|
encode zstd gzip
|
|
reverse_proxy http://localhost:${port}
|
|
'';
|
|
}
|