23 lines
345 B
Nix
23 lines
345 B
Nix
{ lib, ... }:
|
|
{
|
|
imports = [
|
|
./hardware.nix
|
|
];
|
|
|
|
boot.loader = {
|
|
systemd-boot.enable = true;
|
|
efi.canTouchEfiVariables = true;
|
|
};
|
|
|
|
networking.hostName = "hive";
|
|
|
|
motd = {
|
|
networkInterfaces = lib.lists.singleton "eno1";
|
|
servicesToCheck = [
|
|
"caddy"
|
|
"gotosocial"
|
|
"mealie"
|
|
"murmur"
|
|
];
|
|
};
|
|
}
|