diff options
author | tdback <tyler@tdback.net> | 2025-03-05 20:07:01 -0500 |
---|---|---|
committer | tdback <tyler@tdback.net> | 2025-03-05 20:07:01 -0500 |
commit | 134264245ff8b1e6f0347b063b58821a938210f4 (patch) | |
tree | 9587090d787b75b161f10906cd1d5d23924f1194 /flake.nix | |
parent | 4063c2a6e59c9cd5233688db679b80fadf16ad33 (diff) |
flake: add sol server
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 46 |
1 files changed, 33 insertions, 13 deletions
@@ -1,17 +1,14 @@ { - inputs = { - nixpkgs.url = "github:nixos/nixpkgs/nixos-24.11"; - nixpkgs-unstable.url = "github:nixos/nixpkgs/nixos-unstable"; - home-manager = { - url = "github:nix-community/home-manager/release-24.11"; - inputs.nixpkgs.follows = "nixpkgs"; - }; - agenix = { - url = "github:ryantm/agenix"; - inputs.nixpkgs.follows = "nixpkgs"; - }; - deploy-rs.url = "github:serokell/deploy-rs"; - }; + inputs.nixpkgs.url = "github:nixos/nixpkgs/nixos-24.11"; + inputs.nixpkgs-unstable.url = "github:nixos/nixpkgs/nixos-unstable"; + + inputs.home-manager.url = "github:nix-community/home-manager/release-24.11"; + inputs.home-manager.inputs.nixpkgs.follows = "nixpkgs"; + + inputs.agenix.url = "github:ryantm/agenix"; + inputs.agenix.inputs.nixpkgs.follows = "nixpkgs"; + + inputs.deploy-rs.url = "github:serokell/deploy-rs"; outputs = { ... }@inputs: @@ -136,6 +133,29 @@ ]; } ]) + (mkSystem "sol" "x86_64-linux" inputs.nixpkgs [ + { + type = "profiles"; + modules = [ + "common" + "upgrade" + ]; + } + { + type = "scripts"; + modules = [ + "motd" + "pushover" + ]; + } + { + type = "services"; + modules = [ + "ssh" + "xonotic" + ]; + } + ]) (mkSystem "sparrow" "x86_64-linux" inputs.nixpkgs ( inputs.nixpkgs.lib.singleton { type = "profiles"; |