aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authortdback <tyler@tdback.net>2024-12-24 17:08:23 -0500
committertdback <tyler@tdback.net>2024-12-24 17:08:23 -0500
commit3c50eaf6bed7e8fe65d8bd95df77554caa3280b9 (patch)
treecf3a25b00f83b5683ce9392f96d38643f2beed75 /flake.nix
parentb10b5a159161b4e2eb715193693b34849983f092 (diff)
shorten from 'make' to 'mk'
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix14
1 files changed, 7 insertions, 7 deletions
diff --git a/flake.nix b/flake.nix
index 30d31b3..6fe3878 100644
--- a/flake.nix
+++ b/flake.nix
@@ -15,23 +15,23 @@
outputs = { ... }@inputs:
let
helpers = import ./modules { inherit inputs; };
- inherit (helpers) mergeSets makeSystem;
+ inherit (helpers) mergeSets mkSystem;
in
{
nixosConfigurations = mergeSets [
- (makeSystem "woodpecker" inputs.nixpkgs [
+ (mkSystem "woodpecker" inputs.nixpkgs [
{
type = "profiles";
modules = [ "common" "fstrim" "libvirtd" "nvidia" "pipewire" "security" "steam" "wireshark" "x11" ];
}
])
- (makeSystem "sparrow" inputs.nixpkgs [
+ (mkSystem "sparrow" inputs.nixpkgs [
{
type = "profiles";
modules = [ "common" "pipewire" "security" "vpn" "x11" ];
}
])
- (makeSystem "raindog" inputs.nixpkgs [
+ (mkSystem "raindog" inputs.nixpkgs [
{
type = "profiles";
modules = [ "common" "security" "upgrade" ];
@@ -39,7 +39,7 @@
{ type = "scripts"; modules = [ "motd" "pushover" ]; }
{ type = "services"; modules = [ "blocky" "searx" "ssh" ]; }
])
- (makeSystem "oasis" inputs.nixpkgs [
+ (mkSystem "oasis" inputs.nixpkgs [
{
type = "profiles";
modules = [ "common" "podman" "security" "upgrade" "wireguard" "zfs" ];
@@ -50,7 +50,7 @@
modules = [ "cgit" "proxy" "sftpgo" "ssh" ];
}
])
- (makeSystem "hive" inputs.nixpkgs [
+ (mkSystem "hive" inputs.nixpkgs [
{
type = "profiles";
modules = [ "common" "security" "upgrade" "wireguard" ];
@@ -61,7 +61,7 @@
modules = [ "fediverse" "proxy" "ssh" "web" ];
}
])
- (makeSystem "eden" inputs.nixpkgs [
+ (mkSystem "eden" inputs.nixpkgs [
{
type = "containers";
modules = [ "freshrss" "jellyfin" "pinchflat" "vaultwarden" "watchtower" ];