diff options
author | tdback <tyler@tdback.net> | 2025-01-17 19:26:25 -0500 |
---|---|---|
committer | tdback <tyler@tdback.net> | 2025-01-17 19:26:25 -0500 |
commit | 581b132852c492f55a5cc6c657a3d24171708d2e (patch) | |
tree | 5135b7cc73380951d8f456bbe2a21b620fb231e6 /flake.nix | |
parent | a27cf2977656a40dd1f92ed262104f898a065499 (diff) |
feat: add ability to specify system in mkSystem. add loki server
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 29 |
1 files changed, 23 insertions, 6 deletions
@@ -24,7 +24,7 @@ in { nixosConfigurations = mergeSets [ - (mkSystem "frigg" inputs.nixpkgs [ + (mkSystem "frigg" "x86_64-linux" inputs.nixpkgs [ { type = "profiles"; modules = [ @@ -54,7 +54,7 @@ ]; } ]) - (mkSystem "heimdall" inputs.nixpkgs [ + (mkSystem "heimdall" "x86_64-linux" inputs.nixpkgs [ { type = "profiles"; modules = [ @@ -79,7 +79,24 @@ ]; } ]) - (mkSystem "odin" inputs.nixpkgs [ + (mkSystem "loki" "aarch64-linux" inputs.nixpkgs [ + { + type = "profiles"; + modules = [ + "common" + "security" + "upgrade" + ]; + } + { + type = "scripts"; + modules = [ + "motd" + "pushover" + ]; + } + ]) + (mkSystem "odin" "x86_64-linux" inputs.nixpkgs [ { type = "containers"; modules = [ @@ -120,7 +137,7 @@ ]; } ]) - (mkSystem "sparrow" inputs.nixpkgs ( + (mkSystem "sparrow" "x86_64-linux" inputs.nixpkgs ( inputs.nixpkgs.lib.singleton { type = "profiles"; modules = [ @@ -132,7 +149,7 @@ ]; } )) - (mkSystem "thor" inputs.nixpkgs [ + (mkSystem "thor" "x86_64-linux" inputs.nixpkgs [ { type = "profiles"; modules = [ @@ -159,7 +176,7 @@ ]; } ]) - (mkSystem "woodpecker" inputs.nixpkgs ( + (mkSystem "woodpecker" "x86_64-linux" inputs.nixpkgs ( inputs.nixpkgs.lib.singleton { type = "profiles"; modules = [ |