aboutsummaryrefslogtreecommitdiff
path: root/hosts/loki/default.nix
diff options
context:
space:
mode:
authortdback <tyler@tdback.net>2025-01-26 11:31:00 -0500
committertdback <tyler@tdback.net>2025-01-26 11:31:00 -0500
commita7c3d07078d0ca67afadd6fb24ab4b60b38c1109 (patch)
treeb214be5bc6bd1ea67c0499ee54ce3ec06565e929 /hosts/loki/default.nix
parent63883c4dea9ca50a4fd8756323ab04bf66e3dd3d (diff)
hosts: overhauled host configurations
Diffstat (limited to 'hosts/loki/default.nix')
-rw-r--r--hosts/loki/default.nix43
1 files changed, 23 insertions, 20 deletions
diff --git a/hosts/loki/default.nix b/hosts/loki/default.nix
index ca6edab..b4d0da9 100644
--- a/hosts/loki/default.nix
+++ b/hosts/loki/default.nix
@@ -1,8 +1,28 @@
-{ inputs, ... }:
+{
+ inputs,
+ ...
+}:
{
system.stateVersion = "24.11";
- imports = [ ./hardware.nix ];
+ imports = [
+ ./filesystems
+ ./modules
+ ];
+
+ boot.loader.grub = {
+ enable = true;
+ device = "/dev/sda2";
+ efiSupport = true;
+ };
+ boot.initrd = {
+ availableKernelModules = [
+ "xhci_pci"
+ "virtio_scsi"
+ "sr_mod"
+ ];
+ kernelModules = [ "dm-snapshot" ];
+ };
home-manager = {
useGlobalPkgs = true;
@@ -14,26 +34,9 @@
};
};
+ time.timeZone = "America/Detroit";
networking = {
hostName = "loki";
networkmanager.enable = true;
};
-
- time.timeZone = "America/Detroit";
-
- boot.loader.grub = {
- enable = true;
- device = "/dev/sda2";
- efiSupport = true;
- };
-
- programs.motd = {
- enable = true;
- networkInterfaces = [ "enp1s0" ];
- servicesToCheck = [
- "coturn"
- "matrix"
- "postgresql"
- ];
- };
}