aboutsummaryrefslogtreecommitdiff
path: root/hosts/odin/default.nix
diff options
context:
space:
mode:
authortdback <tyler@tdback.net>2025-01-05 12:38:26 -0500
committertdback <tyler@tdback.net>2025-01-05 12:38:26 -0500
commit21a405e977754d31215244cbd4be5eb928732e69 (patch)
tree6eaf61860bb000e745ac3f1662181f41923aa061 /hosts/odin/default.nix
parentff80e2841c2ccbaa0df325269b8a89076da6ce43 (diff)
update server hostnames
Diffstat (limited to 'hosts/odin/default.nix')
-rw-r--r--hosts/odin/default.nix61
1 files changed, 61 insertions, 0 deletions
diff --git a/hosts/odin/default.nix b/hosts/odin/default.nix
new file mode 100644
index 0000000..47515e8
--- /dev/null
+++ b/hosts/odin/default.nix
@@ -0,0 +1,61 @@
+{ lib, inputs, ... }:
+{
+ system.stateVersion = "24.05";
+
+ imports = [ ./hardware.nix ];
+
+ home-manager = {
+ useGlobalPkgs = true;
+ useUserPackages = true;
+ users = import "${inputs.self}/users";
+ extraSpecialArgs = {
+ inherit inputs;
+ headless = true;
+ };
+ };
+
+ networking = {
+ hostName = "odin";
+ hostId = "bd03847d"; # Required for ZFS support.
+ nameservers = [ "10.44.0.1" ];
+ defaultGateway.address = "10.44.0.1";
+ interfaces.eno1 = {
+ useDHCP = false;
+ ipv4.addresses = [{
+ address = "10.44.4.101";
+ prefixLength = 16;
+ }];
+ };
+ };
+
+ time.timeZone = "America/Detroit";
+
+ boot = {
+ loader = {
+ systemd-boot.enable = true;
+ efi.canTouchEfiVariables = true;
+ };
+ zfs.extraPools = [ "tank" ];
+ };
+
+ services.zquota = {
+ enable = true;
+ quotas = {
+ "tank/backups" = 512;
+ "tank/media" = 1536;
+ };
+ };
+
+ programs.motd = {
+ enable = true;
+ networkInterfaces = lib.lists.singleton "eno1";
+ servicesToCheck = [
+ "caddy"
+ "immich-machine-learning"
+ "immich-server"
+ "postgresql"
+ "redis-immich"
+ "zfs-zed"
+ ];
+ };
+}