aboutsummaryrefslogtreecommitdiff
path: root/hosts/odin/default.nix
diff options
context:
space:
mode:
authortdback <tyler@tdback.net>2025-01-26 11:31:00 -0500
committertdback <tyler@tdback.net>2025-01-26 11:31:00 -0500
commita7c3d07078d0ca67afadd6fb24ab4b60b38c1109 (patch)
treeb214be5bc6bd1ea67c0499ee54ce3ec06565e929 /hosts/odin/default.nix
parent63883c4dea9ca50a4fd8756323ab04bf66e3dd3d (diff)
hosts: overhauled host configurations
Diffstat (limited to 'hosts/odin/default.nix')
-rw-r--r--hosts/odin/default.nix67
1 files changed, 33 insertions, 34 deletions
diff --git a/hosts/odin/default.nix b/hosts/odin/default.nix
index 52a2ace..e413d07 100644
--- a/hosts/odin/default.nix
+++ b/hosts/odin/default.nix
@@ -1,8 +1,36 @@
-{ lib, inputs, ... }:
+{
+ inputs,
+ lib,
+ ...
+}:
{
system.stateVersion = "24.05";
- imports = [ ./hardware.nix ];
+ imports = [
+ ./filesystems
+ ./modules
+ ];
+
+ hardware = {
+ enableRedistributableFirmware = true;
+ cpu.intel.updateMicrocode = true;
+ };
+
+ boot.loader = {
+ systemd-boot.enable = true;
+ efi.canTouchEfiVariables = true;
+ };
+ boot.initrd.availableKernelModules = [
+ "xhci_pci"
+ "ehci_pci"
+ "ahci"
+ "usbhid"
+ "usb_storage"
+ "sd_mod"
+ "sr_mod"
+ ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.zfs.extraPools = [ "tank" ];
home-manager = {
useGlobalPkgs = true;
@@ -14,9 +42,11 @@
};
};
+ time.timeZone = "America/Detroit";
networking = {
hostName = "odin";
- hostId = "bd03847d"; # Required for ZFS support.
+ # A host ID is required when enabling ZFS.
+ hostId = "bd03847d";
nameservers = [ "10.44.0.1" ];
defaultGateway.address = "10.44.0.1";
interfaces.eno1 = {
@@ -27,35 +57,4 @@
};
};
};
-
- time.timeZone = "America/Detroit";
-
- boot = {
- loader = {
- systemd-boot.enable = true;
- efi.canTouchEfiVariables = true;
- };
- zfs.extraPools = [ "tank" ];
- };
-
- services.zquota = {
- enable = true;
- quotas = {
- "tank/backups" = 512;
- "tank/media" = 1536;
- };
- };
-
- programs.motd = {
- enable = true;
- networkInterfaces = [ "eno1" ];
- servicesToCheck = [
- "caddy"
- "immich-machine-learning"
- "immich-server"
- "postgresql"
- "redis-immich"
- "zfs-zed"
- ];
- };
}