aboutsummaryrefslogtreecommitdiff
path: root/hosts/sparrow/default.nix
diff options
context:
space:
mode:
authortdback <tyler@tdback.net>2024-12-21 15:32:13 -0500
committertdback <tyler@tdback.net>2024-12-21 15:32:13 -0500
commit0a5754541bb01e96021ca7ee74f1256a8ee68bc4 (patch)
tree2d0b8089e98239963a1e240cff676b1515fc8431 /hosts/sparrow/default.nix
initial commit to self-hosted git
Diffstat (limited to 'hosts/sparrow/default.nix')
-rw-r--r--hosts/sparrow/default.nix43
1 files changed, 43 insertions, 0 deletions
diff --git a/hosts/sparrow/default.nix b/hosts/sparrow/default.nix
new file mode 100644
index 0000000..824f5df
--- /dev/null
+++ b/hosts/sparrow/default.nix
@@ -0,0 +1,43 @@
+{ inputs, pkgs, ... }:
+{
+ system.stateVersion = "24.05";
+
+ imports = [ ./hardware.nix ];
+
+ home-manager = {
+ useGlobalPkgs = true;
+ useUserPackages = true;
+ users = import "${inputs.self}/users";
+ extraSpecialArgs = {
+ inherit inputs;
+ headless = false;
+ };
+ };
+
+ networking = {
+ hostName = "sparrow";
+ networkmanager.enable = true;
+ };
+
+ time.timeZone = "America/Detroit";
+
+ boot = {
+ loader = {
+ systemd-boot.enable = true;
+ efi.canTouchEfiVariables = true;
+ };
+ binfmt.emulatedSystems = [ "aarch64-linux" "riscv64-linux" ];
+ };
+
+ # Since I don't always carry my split keyboard, remap CAPS to left CTRL.
+ console.useXkbConfig = true;
+ services = {
+ xserver.xkb.options = "ctrl:swapcaps";
+ libinput.enable = true;
+ };
+
+ environment.systemPackages = with pkgs; [
+ acpi
+ unstable.qbittorrent
+ ];
+}