aboutsummaryrefslogtreecommitdiff
path: root/modules/profiles/zfs/default.nix
diff options
context:
space:
mode:
authortdback <tyler@tdback.net>2024-12-21 15:32:13 -0500
committertdback <tyler@tdback.net>2024-12-21 15:32:13 -0500
commit0a5754541bb01e96021ca7ee74f1256a8ee68bc4 (patch)
tree2d0b8089e98239963a1e240cff676b1515fc8431 /modules/profiles/zfs/default.nix
initial commit to self-hosted git
Diffstat (limited to 'modules/profiles/zfs/default.nix')
-rw-r--r--modules/profiles/zfs/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/modules/profiles/zfs/default.nix b/modules/profiles/zfs/default.nix
new file mode 100644
index 0000000..8344450
--- /dev/null
+++ b/modules/profiles/zfs/default.nix
@@ -0,0 +1,28 @@
+{ lib, pkgs, ... }:
+{
+ boot = {
+ zfs.forceImportRoot = false;
+ supportedFilesystems.zfs = lib.mkForce true;
+ };
+
+ services.zfs = {
+ autoScrub.enable = true;
+ zed = {
+ enableMail = false;
+ settings = {
+ ZED_DEBUG_LOG = "/tmp/zed.debug.log";
+ ZED_EMAIL_ADDR = [ "root" ];
+ ZED_EMAIL_PROG = "/run/current-system/sw/bin/pushover";
+ ZED_EMAIL_OPTS = "-t '@SUBJECT@'";
+ ZED_NOTIFY_INTERVAL_SECS = 3600;
+ ZED_NOTIFY_VERBOSE = true;
+ ZED_USE_ENCLOSURE_LEDS = true;
+ ZED_SCRUB_AFTER_RESILVER = true;
+ };
+ };
+ };
+
+ environment.systemPackages = with pkgs; [
+ zfs
+ ];
+}