aboutsummaryrefslogtreecommitdiff
path: root/modules/retired/xonotic/default.nix
diff options
context:
space:
mode:
authortdback <tyler@tdback.net>2024-12-21 15:32:13 -0500
committertdback <tyler@tdback.net>2024-12-21 15:32:13 -0500
commit0a5754541bb01e96021ca7ee74f1256a8ee68bc4 (patch)
tree2d0b8089e98239963a1e240cff676b1515fc8431 /modules/retired/xonotic/default.nix
initial commit to self-hosted git
Diffstat (limited to 'modules/retired/xonotic/default.nix')
-rw-r--r--modules/retired/xonotic/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/modules/retired/xonotic/default.nix b/modules/retired/xonotic/default.nix
new file mode 100644
index 0000000..7ae5442
--- /dev/null
+++ b/modules/retired/xonotic/default.nix
@@ -0,0 +1,25 @@
+{ pkgs, ... }:
+{
+ services.xonotic = {
+ enable = true;
+ package = pkgs.xonotic-dedicated;
+ openFirewall = true;
+ settings = {
+ hostname = "tdback's Xonotic Server";
+ net_address = "0.0.0.0";
+ port = 26000;
+ sv_motd = "GLHF! Please report any issues to @tdback on irc.libera.chat";
+
+ # Specify bots and player count.
+ maxplayers = 8;
+ minplayers = 4;
+ minplayers_per_team = 2;
+
+ # Configure mutators.
+ g_instagib = 0;
+ g_grappling_hook = 1;
+ g_jetpack = 0;
+ g_vampire = 0;
+ };
+ };
+}