aboutsummaryrefslogtreecommitdiff
path: root/modules/scripts/pushover/default.nix
diff options
context:
space:
mode:
authortdback <tyler@tdback.net>2025-01-16 19:57:13 -0500
committertdback <tyler@tdback.net>2025-01-16 19:57:13 -0500
commit88017f5a874478dd82f306a5df88c38a8d06fcb6 (patch)
tree8806c58c4f21bb6a56d8530df8a93b256d44b4f3 /modules/scripts/pushover/default.nix
parent01d012473d4311d4f4e5a0831d912bc4b8c61639 (diff)
fix: format flake with `nixfmt-rfc-style`
Diffstat (limited to 'modules/scripts/pushover/default.nix')
-rw-r--r--modules/scripts/pushover/default.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/modules/scripts/pushover/default.nix b/modules/scripts/pushover/default.nix
index a5644e4..979e96b 100644
--- a/modules/scripts/pushover/default.nix
+++ b/modules/scripts/pushover/default.nix
@@ -1,4 +1,9 @@
-{ inputs, config, pkgs, ... }:
+{
+ inputs,
+ config,
+ pkgs,
+ ...
+}:
let
pushover = pkgs.writeShellScriptBin "pushover" ''
set -e
@@ -35,7 +40,8 @@ let
--form-string "message=$MESSAGE" \
https://api.pushover.net/1/messages.json
'';
-in {
+in
+{
age.secrets = {
pushoverAppToken.file = "${inputs.self}/secrets/pushoverAppToken.age";
pushoverUserToken.file = "${inputs.self}/secrets/pushoverUserToken.age";