aboutsummaryrefslogtreecommitdiff
path: root/modules/services/xonotic/default.nix
diff options
context:
space:
mode:
authortdback <tyler@tdback.net>2025-03-06 21:29:29 -0500
committertdback <tyler@tdback.net>2025-03-06 21:29:29 -0500
commit14b6877ed989ec65eb95f2db5ef5927ee46b1300 (patch)
tree71d323457b946c71a6b10cab9ca5deff17f84003 /modules/services/xonotic/default.nix
parent88b90e6fb4354dd592a62a8713ee7ed405b781e8 (diff)
xonotic: add option to set bot skill level
Diffstat (limited to 'modules/services/xonotic/default.nix')
-rw-r--r--modules/services/xonotic/default.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/modules/services/xonotic/default.nix b/modules/services/xonotic/default.nix
index 5b29d36..33d45e2 100644
--- a/modules/services/xonotic/default.nix
+++ b/modules/services/xonotic/default.nix
@@ -37,6 +37,11 @@ in
default = 4;
type = types.int;
};
+ skill = mkOption {
+ default = 5;
+ type = types.int;
+ description = "Sets the skill level of any bots. Higher values mean harder bots.";
+ };
g_mutators = mkOption {
default = { };
type = types.attrsOf types.bool;
@@ -58,6 +63,7 @@ in
maxplayers = cfg.maxplayers;
minplayers = cfg.minplayers;
minplayers_per_team = cfg.minplayers / 2;
+ skill = cfg.skill;
} // (setMutators cfg.g_mutators);
};
};