aboutsummaryrefslogtreecommitdiff
path: root/modules/users/default.nix
diff options
context:
space:
mode:
authortdback <tyler@tdback.net>2024-12-21 15:32:13 -0500
committertdback <tyler@tdback.net>2024-12-21 15:32:13 -0500
commit0a5754541bb01e96021ca7ee74f1256a8ee68bc4 (patch)
tree2d0b8089e98239963a1e240cff676b1515fc8431 /modules/users/default.nix
initial commit to self-hosted git
Diffstat (limited to 'modules/users/default.nix')
-rw-r--r--modules/users/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/modules/users/default.nix b/modules/users/default.nix
new file mode 100644
index 0000000..027ca0f
--- /dev/null
+++ b/modules/users/default.nix
@@ -0,0 +1,15 @@
+{ pkgs, ... }:
+{
+ users = {
+ users.tdback = {
+ isNormalUser = true;
+ uid = 1000;
+ home = "/home/tdback";
+ group = "tdback";
+ extraGroups = [ "wheel" "users" "networkmanager" "video" "audio" ];
+ shell = pkgs.bash;
+ ignoreShellProgramCheck = true;
+ };
+ groups.tdback.gid = 1000;
+ };
+}