aboutsummaryrefslogtreecommitdiff
path: root/users/tdback/desktop.nix
diff options
context:
space:
mode:
authortdback <tyler@tdback.net>2024-12-21 15:32:13 -0500
committertdback <tyler@tdback.net>2024-12-21 15:32:13 -0500
commit0a5754541bb01e96021ca7ee74f1256a8ee68bc4 (patch)
tree2d0b8089e98239963a1e240cff676b1515fc8431 /users/tdback/desktop.nix
initial commit to self-hosted git
Diffstat (limited to 'users/tdback/desktop.nix')
-rw-r--r--users/tdback/desktop.nix70
1 files changed, 70 insertions, 0 deletions
diff --git a/users/tdback/desktop.nix b/users/tdback/desktop.nix
new file mode 100644
index 0000000..e2f754b
--- /dev/null
+++ b/users/tdback/desktop.nix
@@ -0,0 +1,70 @@
+{ config, pkgs, ... }:
+let
+ dirs = [ "desktop" "documents" "download" "music" "pictures" "publicShare" "templates" "videos" ];
+ defined = {
+ "documents" = "${config.home.homeDirectory}/documents";
+ "download" = "${config.home.homeDirectory}/downloads";
+ };
+ userDirs =
+ builtins.map (dir: { name = dir; value = defined.${dir} or null; }) dirs
+ |> builtins.listToAttrs;
+in
+{
+ imports = [
+ ./modules/alacritty
+ ./modules/dunst
+ ./modules/email
+ ./modules/firefox
+ ./modules/irc
+ ./modules/mpd
+ ./modules/ncmpcpp
+ ./modules/neomutt
+ ./modules/polybar
+ ./modules/rofi
+ ./modules/tmux
+ ./modules/x11
+ ];
+
+ home.packages = with pkgs.unstable; [
+ clang
+ feh
+ (ffmpeg.override { withXcb = true; })
+ flameshot
+ gimp
+ gitu
+ mpc-cli
+ mpv
+ pavucontrol
+ pamixer
+ pciutils
+ signal-desktop
+ sxiv
+ tidal-dl
+ xclip
+ yt-dlp
+ zathura
+ ];
+
+ xdg = {
+ enable = true;
+ userDirs = {
+ enable = true;
+ createDirectories = true;
+ } // userDirs;
+ };
+
+ qt = {
+ enable = true;
+ platformTheme.name = "gtk3";
+ style = {
+ name = "adwaita-dark";
+ package = pkgs.adwaita-qt;
+ };
+ };
+
+ gtk = {
+ enable = true;
+ gtk3.extraConfig.gtk-application-prefer-dark-theme = 1;
+ gtk4.extraConfig.gtk-application-prefer-dark-theme = 1;
+ };
+}