aboutsummaryrefslogtreecommitdiff
path: root/users/tdback/modules/editor/default.nix
diff options
context:
space:
mode:
authortdback <tyler@tdback.net>2025-03-15 14:49:06 -0400
committertdback <tyler@tdback.net>2025-03-15 14:49:06 -0400
commit87ed172749c656861a43dbf3640fe58291d8032f (patch)
treeb0c2ee655ab71c4b0199ca278f31174e3245770d /users/tdback/modules/editor/default.nix
parenteaf1b9f486188ae9133ecd47d67ec05305e74e53 (diff)
editor: renamed from emacs module. include all dependencies
Diffstat (limited to 'users/tdback/modules/editor/default.nix')
-rw-r--r--users/tdback/modules/editor/default.nix44
1 files changed, 44 insertions, 0 deletions
diff --git a/users/tdback/modules/editor/default.nix b/users/tdback/modules/editor/default.nix
new file mode 100644
index 0000000..0a45011
--- /dev/null
+++ b/users/tdback/modules/editor/default.nix
@@ -0,0 +1,44 @@
+# users/tdback/modules/editor/default.nix
+#
+# My primary editor for writing code, checking mail, and doing other emacs-y
+# things.
+#
+# TODO: Use unstable epkgs to get mail working with the standalone binary.
+
+{
+ pkgs,
+ ...
+}:
+{
+ # Provide emacs and emacsclient.
+ programs.emacs = {
+ enable = true;
+ package = pkgs.unstable.emacs30-gtk3;
+ extraPackages =
+ epkgs: with epkgs; [
+ jinx # spell-checker
+ mu4e # mail client
+ ];
+ };
+
+ # Run emacs as a systemd daemon in graphical environments.
+ services.emacs = {
+ enable = true;
+ package = pkgs.unstable.emacs30-gtk3;
+ startWithUserSession = "graphical";
+ defaultEditor = true;
+ client.enable = true;
+ };
+
+ # Include any package dependencies used in my emacs configuration.
+ home.packages = with pkgs.unstable; [
+ nixd # editing nix code
+ ripgrep # faster searches
+ emacsPackages.jinx # spell-checker package
+ enchant # spell-checker library
+ hunspellDicts.en-us-large # spell-checker dictionary
+ hledger # finances
+ imagemagick # viewing images
+ mu # mail client
+ ];
+}