aboutsummaryrefslogtreecommitdiff
path: root/users/tdback/modules/retired/dunst/default.nix
diff options
context:
space:
mode:
authortdback <tyler@tdback.net>2025-01-16 20:19:38 -0500
committertdback <tyler@tdback.net>2025-01-16 20:19:38 -0500
commit05eca99c7e169d98676f9997393b347e3754d113 (patch)
tree63d8c68ce4dc463031db525eb8296de36b099432 /users/tdback/modules/retired/dunst/default.nix
parent88017f5a874478dd82f306a5df88c38a8d06fcb6 (diff)
chore: move retired modules into modules subdir
Diffstat (limited to 'users/tdback/modules/retired/dunst/default.nix')
-rw-r--r--users/tdback/modules/retired/dunst/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/users/tdback/modules/retired/dunst/default.nix b/users/tdback/modules/retired/dunst/default.nix
new file mode 100644
index 0000000..4b52def
--- /dev/null
+++ b/users/tdback/modules/retired/dunst/default.nix
@@ -0,0 +1,27 @@
+{ pkgs, ... }:
+{
+ services.dunst = {
+ enable = true;
+ package = pkgs.unstable.dunst;
+ settings = {
+ global = {
+ width = 300;
+ height = 300;
+ offset = "30x50";
+ origin = "top-right";
+ frame_color = "#2c363c";
+ font = "Iosevka Comfy Motion Fixed 12";
+ };
+ urgency_normal = {
+ background = "#37474f";
+ foreground = "eceff1";
+ timeout = 5;
+ };
+ };
+ iconTheme = {
+ name = "Papirus-Dark";
+ package = pkgs.papirus-icon-theme;
+ size = "16x16";
+ };
+ };
+}