aboutsummaryrefslogtreecommitdiff
path: root/users/tdback/retired/dunst/default.nix
diff options
context:
space:
mode:
authortdback <tyler@tdback.net>2025-01-10 19:20:18 -0500
committertdback <tyler@tdback.net>2025-01-10 19:20:18 -0500
commitb8e2eb59a2b84820719e5f6f334fbfbc05019c52 (patch)
treef34acba50e860961c7660a1021264613e9531ef1 /users/tdback/retired/dunst/default.nix
parent91646e9d50a55e21141f98b4fb396296e22c052a (diff)
feat: retire x11 and go full COSMIC/wayland on workstations
Diffstat (limited to 'users/tdback/retired/dunst/default.nix')
-rw-r--r--users/tdback/retired/dunst/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/users/tdback/retired/dunst/default.nix b/users/tdback/retired/dunst/default.nix
new file mode 100644
index 0000000..4b52def
--- /dev/null
+++ b/users/tdback/retired/dunst/default.nix
@@ -0,0 +1,27 @@
+{ pkgs, ... }:
+{
+ services.dunst = {
+ enable = true;
+ package = pkgs.unstable.dunst;
+ settings = {
+ global = {
+ width = 300;
+ height = 300;
+ offset = "30x50";
+ origin = "top-right";
+ frame_color = "#2c363c";
+ font = "Iosevka Comfy Motion Fixed 12";
+ };
+ urgency_normal = {
+ background = "#37474f";
+ foreground = "eceff1";
+ timeout = 5;
+ };
+ };
+ iconTheme = {
+ name = "Papirus-Dark";
+ package = pkgs.papirus-icon-theme;
+ size = "16x16";
+ };
+ };
+}