aboutsummaryrefslogtreecommitdiff
path: root/hosts/odin/modules/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/odin/modules/default.nix')
-rw-r--r--hosts/odin/modules/default.nix50
1 files changed, 50 insertions, 0 deletions
diff --git a/hosts/odin/modules/default.nix b/hosts/odin/modules/default.nix
new file mode 100644
index 0000000..0a7aba1
--- /dev/null
+++ b/hosts/odin/modules/default.nix
@@ -0,0 +1,50 @@
+{
+ modules = {
+ containers.watchtower.enable = true;
+ containers.pinchflat = {
+ enable = true;
+ mediaDir = "/tank/media/yt";
+ };
+ containers.freshrss = {
+ enable = true;
+ url = "fresh.brownbread.net";
+ };
+ containers.lubelogger = {
+ enable = true;
+ url = "garage.brownbread.net";
+ };
+ containers.vaultwarden = {
+ enable = true;
+ url = "steel-mountain.brownbread.net";
+ };
+ containers.jellyfin = {
+ enable = true;
+ url = "buttered.brownbread.net";
+ mediaDir = "/tank/media";
+ };
+ services.immich = {
+ enable = true;
+ url = "photographs.brownbread.net";
+ mediaDir = "/tank/immich";
+ };
+ scripts.motd = {
+ enable = true;
+ networkInterfaces = [ "eno1" ];
+ servicesToCheck = [
+ "caddy"
+ "immich-machine-learning"
+ "immich-server"
+ "postgresql"
+ "redis-immich"
+ "zfs-zed"
+ ];
+ };
+ scripts.zquota = {
+ enable = true;
+ quotas = {
+ "tank/backups" = 512;
+ "tank/media" = 1536;
+ };
+ };
+ };
+}