aboutsummaryrefslogtreecommitdiff
path: root/modules/customs/soft-serve/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/customs/soft-serve/default.nix')
-rw-r--r--modules/customs/soft-serve/default.nix15
1 files changed, 10 insertions, 5 deletions
diff --git a/modules/customs/soft-serve/default.nix b/modules/customs/soft-serve/default.nix
index 05156fd..102ee1c 100644
--- a/modules/customs/soft-serve/default.nix
+++ b/modules/customs/soft-serve/default.nix
@@ -1,4 +1,9 @@
-{ config, lib, pkgs, ... }:
+{
+ config,
+ lib,
+ pkgs,
+ ...
+}:
with lib;
let
cfg = config.services.soft-serve;
@@ -39,10 +44,10 @@ in
systemd.services.soft-serve = {
description = "Soft Serve git server";
- documentation = lists.singleton docUrl;
- requires = lists.singleton "network-online.target";
- after = lists.singleton "network-online.target";
- wantedBy = lists.singleton "multi-user.target";
+ documentation = [ docUrl ];
+ requires = [ "network-online.target" ];
+ after = [ "network-online.target" ];
+ wantedBy = [ "multi-user.target" ];
environment.SOFT_SERVE_DATA_PATH = dataDir;
serviceConfig = {
Type = "simple";