aboutsummaryrefslogtreecommitdiff
path: root/users/tdback/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/tdback/default.nix')
-rw-r--r--users/tdback/default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/users/tdback/default.nix b/users/tdback/default.nix
new file mode 100644
index 0000000..8457428
--- /dev/null
+++ b/users/tdback/default.nix
@@ -0,0 +1,32 @@
+{ config, lib, pkgs, headless ? true, ... }:
+{
+ # Hacky way to import our desktop modules if we aren't a headless system.
+ imports = (lib.optional (!headless) ./desktop.nix) ++ [
+ ./modules/git
+ ./modules/shell
+ ];
+
+ home = {
+ username = "tdback";
+ homeDirectory = "/home/tdback";
+ stateVersion = "24.05";
+ packages = with pkgs.unstable; [
+ age
+ bat
+ croc
+ dig
+ file
+ fzf
+ jq
+ neovim
+ nixd
+ ripgrep
+ tealdeer
+ unzip
+ zip
+ ];
+ };
+
+ # Let home manager install and manage itself.
+ programs.home-manager.enable = true;
+}