aboutsummaryrefslogtreecommitdiff
path: root/users/tdback/modules/dunst/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/tdback/modules/dunst/default.nix')
-rw-r--r--users/tdback/modules/dunst/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/users/tdback/modules/dunst/default.nix b/users/tdback/modules/dunst/default.nix
new file mode 100644
index 0000000..132e32b
--- /dev/null
+++ b/users/tdback/modules/dunst/default.nix
@@ -0,0 +1,30 @@
+{ pkgs, ... }:
+{
+ services.dunst = {
+ enable = true;
+ package = pkgs.dunst;
+
+ settings = {
+ global = {
+ width = 300;
+ height = 300;
+ offset = "30x50";
+ origin = "top-right";
+ frame_color = "#2c363c";
+ font = "Iosevka Comfy Motion Fixed 12";
+ };
+
+ urgency_normal = {
+ background = "#37474f";
+ foreground = "eceff1";
+ timeout = 5;
+ };
+ };
+
+ iconTheme = {
+ name = "Papirus-Dark";
+ package = pkgs.papirus-icon-theme;
+ size = "16x16";
+ };
+ };
+}