aboutsummaryrefslogtreecommitdiff
path: root/users/tdback/modules/xmonad/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/tdback/modules/xmonad/default.nix')
-rw-r--r--users/tdback/modules/xmonad/default.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/users/tdback/modules/xmonad/default.nix b/users/tdback/modules/xmonad/default.nix
index b11f82b..9ddb0c1 100644
--- a/users/tdback/modules/xmonad/default.nix
+++ b/users/tdback/modules/xmonad/default.nix
@@ -1,3 +1,9 @@
+# users/tdback/modules/xmonad/default.nix
+#
+# A purely functional window manager. While I've enjoyed using bspwm/sxhkd with
+# polybar in the past, I love the hackability of xmonad and its integration
+# with xmobar.
+
{
lib,
pkgs,
@@ -11,6 +17,7 @@ in
xsession.windowManager.xmonad = {
enable = true;
enableContribAndExtras = true;
+ # Use the latest version of xmonad available in nixpkgs.
extraPackages = haskellPackages: [
haskellPackages.xmonad_0_18_0
haskellPackages.xmonad-contrib_0_18_1
@@ -48,7 +55,7 @@ in
'';
};
- # Generate X11 init scripts.
+ # Generate X11 init scripts to launch xmonad on login.
home.file = with pkgs.unstable; {
".xinitrc".text = ''
[ -f ~/.xprofile ] && . ~/.xprofile