diff options
author | tdback <tyler@tdback.net> | 2025-01-22 21:41:07 -0500 |
---|---|---|
committer | tdback <tyler@tdback.net> | 2025-01-22 21:41:37 -0500 |
commit | 4e963dc59077e982e61b00826ecd9700bc1ee50a (patch) | |
tree | 6df6267499e2032da65e6f33e2a57b5015c661e3 /flake.nix | |
parent | 37f19ea34af4e61e4f2b519e6e232979125b718a (diff) |
feat: move deploy script into flake shell environment
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 10 |
1 files changed, 9 insertions, 1 deletions
@@ -4,7 +4,10 @@ outputs = { nixpkgs, ... }: let - supportedSystems = [ "x86_64-linux" ]; + supportedSystems = [ + "aarch64-linux" + "x86_64-linux" + ]; eachSystem = nixpkgs.lib.genAttrs supportedSystems; in { @@ -17,6 +20,7 @@ default = pkgs.mkShell { buildInputs = with pkgs; [ hugo + rsync ]; shellHook = '' @@ -31,6 +35,10 @@ POST="$SITE/content/posts/$1" [ -d $POST ] && rm -r $POST } + + deploy() { + hugo && rsync -avz --delete public/ thor:/var/www/tdback.net/ + } ''; }; } |