diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 26 |
1 files changed, 13 insertions, 13 deletions
@@ -1,4 +1,6 @@ { + description = "tdback's website source code (tdback.net)"; + inputs.nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable"; outputs = @@ -9,27 +11,25 @@ "x86_64-linux" ]; eachSystem = nixpkgs.lib.genAttrs supportedSystems; + forPkgs = + fn: + nixpkgs.lib.mapAttrs (system: pkgs: (fn pkgs)) ( + nixpkgs.lib.getAttrs supportedSystems nixpkgs.legacyPackages + ); in { + packages = forPkgs (pkgs: { + default = pkgs.callPackage ./default.nix { }; + }); + devShells = eachSystem ( system: let pkgs = import nixpkgs { inherit system; }; in { - default = pkgs.mkShell { - buildInputs = with pkgs; [ - hugo - rsync - ]; - - shellHook = '' - SITE="$HOME/projects/tdback.net" - - publish() { - hugo && rsync -avz --delete public/ thor:/var/www/tdback.net/ - } - ''; + default = with pkgs; mkShell { + buildInputs = [ hugo ]; }; } ); |