summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..02c06c7
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,26 @@
+{
+ inputs.nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
+ outputs =
+ { nixpkgs, ... }:
+ let
+ supportedSystems = [ "x86_64-linux" ];
+ eachSystem = nixpkgs.lib.genAttrs supportedSystems;
+ in
+ {
+ devShells = eachSystem (
+ system:
+ let
+ pkgs = import nixpkgs { inherit system; };
+ in
+ {
+ default = pkgs.mkShell {
+ buildInputs = with pkgs; [
+ (haskellPackages.ghcWithPackages (
+ ps: with ps; [ haskell-language-server ]
+ ))
+ ];
+ };
+ }
+ );
+ };
+}