summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authortdback <tyler@tdback.net>2025-02-09 20:02:15 -0500
committertdback <tyler@tdback.net>2025-02-09 20:02:15 -0500
commitf06c0ba60216a866e59fd785be6d4abd6874cc2b (patch)
treeeb18acd7cc963415c69267db331511616ca414fa /flake.nix
parent9fbfde3ae45cbdce118b5c9cc80b7b0cd3af0737 (diff)
flake: use direnv, remove alias conflict with deploy-rs
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix12
1 files changed, 1 insertions, 11 deletions
diff --git a/flake.nix b/flake.nix
index 450b803..ced5e60 100644
--- a/flake.nix
+++ b/flake.nix
@@ -26,17 +26,7 @@
shellHook = ''
SITE="$HOME/projects/tdback.net"
- new-post() {
- hugo new "$SITE/content/posts/$1/index.md"
- $EDITOR "$SITE/content/posts/$1/index.md"
- }
-
- del-post() {
- POST="$SITE/content/posts/$1"
- [ -d $POST ] && rm -r $POST
- }
-
- deploy() {
+ publish() {
hugo && rsync -avz --delete public/ thor:/var/www/tdback.net/
}
'';