summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix12
1 files changed, 1 insertions, 11 deletions
diff --git a/flake.nix b/flake.nix
index 450b803..ced5e60 100644
--- a/flake.nix
+++ b/flake.nix
@@ -26,17 +26,7 @@
shellHook = ''
SITE="$HOME/projects/tdback.net"
- new-post() {
- hugo new "$SITE/content/posts/$1/index.md"
- $EDITOR "$SITE/content/posts/$1/index.md"
- }
-
- del-post() {
- POST="$SITE/content/posts/$1"
- [ -d $POST ] && rm -r $POST
- }
-
- deploy() {
+ publish() {
hugo && rsync -avz --delete public/ thor:/var/www/tdback.net/
}
'';